Chat with us, powered by LiveChat
Notifications
Clear all

[Sticky] Epson Repair Service USA

13 Posts
9 Users
0 Likes
601 Views
Posts: 22
(@brian123)
Eminent Member
Joined: 2 years ago

Hi,

I'm having some problems with my Epson 3880. I'm running Mac OS X El Capitan and printing from Photoshop CS5 (have tried printing from the Preview application also). The printer is printing the first ~5 inches of the image but cutting off the rest of it (see attached photo). In the photo, you can see the results of a few of my attempts, and I canceled the print jobs once I saw that only part of the image was being printed.

Has anyone else run into this problem? Ideas on how to fix it?

Reply
Tony Stark
Posts: 17
(@ibtonystark)
Active Member
Joined: 2 years ago

Hello, My name is Tony Stark. I am using an Epson Projector Model Epson BrightLink 425Wi. I need your assistance in fixing it. I am unable to connect my projector to my Computer. I try it again and again. Now I am looking for a third-party repair service center in the USA to resolve these issues? Please suggest me?

Reply
1 Reply
(@elinajohn022)
Joined: 2 years ago

Eminent Member
Posts: 31

Hello,

As you stated you are unable to connect your Epson projector to your computer, here’s the quickest way to do the process:

  • First of all, disconnect your computer’s monitor cable.
  • Now, connect the VGA cable to your computer’s monitor port.
  • Connect the other end to a computer port.
  • Gently, tighten the screws on the VGA connectors.

If you have already tried this process and are still having trouble, then only the Epson repair service center can help get rid of it. All you need to do is to visit here and use your area code. This way you will be able to search for the best and most reliable service provider for your printer repair.

Reply
Posts: 13
(@anshrusso)
Active Member
Joined: 2 years ago

It appears that my Epson ET-2760 is connected to my laptop via a USB cable, but when I try to scan something with the intention of sending it to my laptop, the step where I try to select the computer via the printer screen, after selecting "USB Connection" and pressing "OK," it displays "invalid" on the screen. I downloaded and installed the driver package from the Epson website, but that didn't work. Any suggestions?

Any help would be greatly appreciated.

Reply
Posts: 9
(@jmaxjack)
Active Member
Joined: 2 years ago

Hi, I'm Maxjack from New York. I recently purchased a EcoTank L130 Laser Multifunction Printer for my office, but for the last few days, I've been experiencing slow printing speeds and low printing colors. What is the best way to troubleshoot a printer problem? Its effects on my work. If you know of a good repair service center near me, please let me know.

Reply
Page 2 / 2
Share: